User Avatar Image

Poker Night 2 on Mac Graphic Issue

posted by herr_josua on - last edited - Viewed by 1.4K users
I just installed Poker Night 2 on my Macbook Pro Retina via Steam and during the opening sequence I noticed that some of the character models are messed up. It appears that one of the vertex's of the character model are off screen somewhere. I attempted to uninstall and reinstall. Nothing so far has resolved this issue. My MacBook Pro Retina is 2.6 Ghz, 16Gb of ram, 512Gb SSD, and a NVIDIA GeForce GT 650M 1024 MB.
8 Comments - Linear Discussion: Classic Style
  • I also get this gfx glitch. I also get a black screen at random times. I have to close the game and restart. I also get random lock ups. I tried this on my macbook pro and my mac mini.
  • Here's an example of a graphical glitch both me and my friend are having (screenshots are courtesy their Steam account). We're both Mac users.

    http://steamcommunity.com/sharedfiles/filedetails/?id=141443750
  • I get a problem where all the color is blue and the game freezes my entire mac.
  • I have the same problem with vertexes going randomly off the screen and other random mac bugs. The first night I played, the host was suspiciously transparent. Since then, there's a ray going from Brock's right eye going down through his arm and to the floor. Ash has a smaller ray going from his eyebrow diagonally up towards the ceiling. The host has a very wide ray coming from somewhere in his belly or pants, obscuring most of the host. (Sometimes it's worse, and I have to restart the game until the vertex issue goes down to an acceptable amount of annoyance.)

    This is a common problem with Wine and Wine-based ports on both Linux and Mac. Because of this bug, I'm guessing this is a Cider port?

    Update: Restarting my Mac (which I almost NEVER do, but I was desperate) fixed most of the graphics bugs. At this point, the only problem is that part of the host's uniform is transparent. Since we don't see him most of the time, that's pretty much okay.
  • I am also having the same glitch: 2010 Macbook Pro with 512MB Nvidia 330M card, 8GB RAM. 10.8.3. Came on here to post a screenshot, thanks to medacris for doing so already.
  • Same glitch as Medacris and Elzbal. 3.4Ghz i7 ,10.8.3, NVIDIA GeForce GTX 680MX 2048 MB
  • Not sure if this helps but Wolfcape fixed his issue but turning off switchable graphics. More info here http://www.telltalegames.com/forums/showthread.php?t=45808
  • Yeah turning off Graphic Switching did not solve this issue for me. I still get GFX issues and lockups
This discussion has been closed.