User Avatar Image

TWD 400 Days - Problem

posted by HpZero on - Viewed by 896 users


So, i bought the dlc from the US store, and i want to play it on my UK account, the problem is, when i try to play it, it says : "Coming soon". The thing is, I did the same with the game, bought it from the US store, and played it on my UK account, all five episodes, no problem.

What should I do ?

  • User Avatar Image
    TelltaleMike Telltale Staff

    Can you please clarify which versions you are playing? Are you playing the UK version of the game with the US DLC? If this is the case, the DLC will not be compatible with a version of the game from another region. If the problem persists, you may be able to play while signed into your US account. If none of these suggestions seem to solve your issue, please contact our support staff at

    • Both the game and the dlc are the US version. Im just trying to play the game on my UK account, but i can't seem to be able to play the dlc, even though i was able to play the us version of the game, on the uk account.

      • User Avatar Image
        TelltaleMike Telltale Staff

        Can you please clarify if you have the disc version or the digital version of the game? Also, what is the age rating on the game? This will help narrow down what issue you are experiencing.

        • I have the digital version.

          • Umm, now i have another problem, i can't play the game, when i try to play episode 2,3,4 or 5 it says Coming Soon, only the first one is playable, i downloaded again the episodes just to be sure, but i still can't play it. I tried to play it on the US account, on the uk account i have the option of buying the episodes.
            This is annoying as SH!T.

            • I finally found the solution to this problem. I deleted the game from the game data utility, i downloaded the first episode from the store, wich is free, and when i enter the game, all the episodes are playable , the dlc also. and is playable both on the us and the uk account.

              If there is someone who encountered this problem, i hope this will help.

This discussion has been closed.