Says I dont own the game

The log in servers are finally working, but now it tells me i dont even own the game. But the website clearly shows that I do own this game. So I am still unable to play


  • It's saying that for me as well. Frustrating!

  • Yeah, Im having that trouble as well :(. I've tried re-logging and restarting the game several times, but I can't play :(.

  • This problem is affecting me also. First time it said it can't connect with the servers, now I don't own the game. I imagine they've having some network and database issues. Hopefully will be resolved soon.

  • Telltale please get your shit together!

  • Same here... i pre-ordered like a month ago...they got my money (i can prove with receipt)...i downloaded the game and started it ... it tells me to login .. and after the game tells me i dont own the game i need to buy it first...pls fix fast =(

  • edited December 2013

    I got the exact same problem! First I could'nt login, and now this??? I'll NEVER buy another game from telltale website, I've had so many problems that it's not worth it!
    Note: I HAVE bought the game, I HAVE redeemed the code on telltale website, the game IS under "my games" ! WTF IS WRONG??

    Alt text

  • I've gotta say though, it's a pretty cool looking screen :D

  • It'd be even cooler if it worked.

  • edited December 2013

    I bet you this is happening just so we can see it, they've on purposely locked us out so we can admire their beautiful screen :D.

    Edit: Ok, I'm done looking at it, where's my game? :D

  • Horray, it worked for me! Hopefully they've fixed it for everone :D

  • TelltaleMikeTelltaleMike Former Telltale Staff

    We have now solved the server issue, please restart the game and attempt to log in again, and the issue should be resolved. If you are still experiencing log in errors, please reply with what your error message says, and whether you are on PC or Mac, and whether your on Steam or playing through Telltale. I apologize for any inconvenience this has caused.

This discussion has been closed.