User Avatar Image

howto: get SBCG4AP 101 (demo and full game) running on Linux

posted by tremby on - last edited - Viewed by 10.4K users
Strong Bad's Cool Game for Attractive People episodes 101 and 102 howto: get them running in Linux
by demonfoo and tremby

the commands in this howto (and some of the files linked) are specific to Ubuntu Hardy Heron. a similar procedure should work for other distros, though.

[*] install Wine 1.1.3 or later
[*] if you haven't already, add WineHQ's repository to your package manager. (instructions from WineHQ)
[*] add the repository's key so packages can be authenticated by running
wget -q -O- | sudo apt-key add -

[*] add the repository to the list of sources by running
sudo wget -O /etc/apt/sources.list.d/winehq.list

[*] refresh your package list by running
sudo apt-get update

[*] install or upgrade Wine by running
sudo apt-get install wine

[*] install IEs4Linux
[*] first we need cabextract and tar. we'll get the MS fonts while we're at it. install them by running
sudo apt-get install cabextract tar msttcorefonts

[*] then download and extract IEs4Linux by running
wget -O- | tar zx

[*] move into the IEs4Linux directory by running
cd ies4linux-*

[*] load the installer by running

it'll complain on the command line that you're running an old version of Wine, but it's lying.
[*] install it. the default options are fine for the purposes of this howto, but since i'm a web developer i install IE7 too by clicking "advanced" and then checking IE7's box. close the installer when it's done.
[*] move back out of the IEs4Linux directory by running
cd ..

[*] set up Wine for SBCG4AP and install the game
[*] copy the WINEPREFIX ("drive C") for IE6 to make one for SBCG4AP which has IE6 installed by running
cp -a ~/.ies4linux/ie6 ~/.wine_sbcg4ap

[*] download the Homestar Ruiner demo installer with your browser (i'll assume to your desktop) or by running
wget -O ~/Desktop/homestarruinerdemo.exe

[*] start the installer by running
env WINEPREFIX=$HOME/.wine_sbcg4ap WINEDLLOVERRIDES=\"rpcrt4,ole32,d3d9=b\" wine ~/Desktop/homestarruinerdemo.exe

[*] follow its instructions. the default paths are fine, and be sure to answer "yes" to the question about installing DirectX. uncheck "Play now" when it's done and click "Finish". then you can delete the installer if you like by selecting it and hitting delete or running
rm ~/Desktop/homestarruinerdemo.exe

[*] set up Wine for this WINEPREFIX (and therefore the game)
[*] run the Wine config tool with the game's WINEPREFIX by running
env WINEPREFIX=$HOME/.wine_sbcg4ap winecfg

[*] on the "Applications" tab, set the Windows version to Windows XP
[*] on the Audio tab, say OK to the box telling you to edit your audio settings and it will set some defaults. check they make sense.
[*] add DLL overrides. to do this, go to the "Libraries" tab and add each of the following:
  • d3d9
  • ole32
  • rpcrt4
by choosing from the list (or typing) and then clicking add, for each.
[*] for each of the overrides above, click its entry in the list of "Existing overrides" and click "Edit". choose "Built-in (Wine)" from the menu and click OK.
[*] optional (do this if you're having problems with the game screen or just want to run in a window): on the "Graphics" tab, check "Emulate a virtual desktop" and enter the resolution you want.
[*] click "Apply" and then "Close"
[*] start the game
double click the launcher, enter your My Telltale login information (if asked) and then click on the green area at right about the level of Strong Bad's feet; unfortunately the image that should be there doesn't appear.

to install the second episode, make sure you run the installer in your SBCG4AP environment:
env WINEPREFIX=$HOME/.wine_sbcg4ap wine ~/Desktop/Strong_Badia_the_Free_setup.exe

this time, you can say no to the DirectX question. if you do, you need to put a link to the DLL which the DirectX installer would have added (already in the Episode 1 directory) for Episode 2 after installing by running
ln -s \"../Episode 1 - Homestar Ruiner/d3dx9_27.dll\" ~/.wine_sbcg4ap/drive_c/\"Program Files/Telltale Games/Strong Bad/Episode 2 - Strong Badia the Free/\"

then the launcher the game puts on your desktop should work just fine.

to install the third, do the same stuff as for the second, but the link command will be a tad different:
ln -s \"../Episode 1 - Homestar Ruiner/d3dx9_27.dll\" ~/.wine_sbcg4ap/drive_c/\"Program Files/Telltale Games/Strong Bad/Episode 3 - Baddest of the Bands/\"
96 Comments - Linear Discussion: Classic Style
  • User Avatar Image
    We thew in the _27 if the install didn't detect the _27 file. That way if you didn't do DirectX, you could at least launch the game and not get a scary and uninformative error message. Technically we could put all of the DX files there, but that's even scarier.

    The executable first looks for the DX DLLs at the same folder the EXE lives, then looks in the SYSTEM32 folder.
  • Just for the record, I downloaded the DirectX9 D3D update redistributables (which someone has handily collected at and extracted all the d3dx9_*.dll files, and placed them into the Wine equivalent of C:\windows\system32. This includes all the ones mentioned in Seg's earlier post; however, this didn't stop the disappearing eyes bug from hitting some of the time (loaded perfectly once, then next try, bye bye eyes). I don't see anything in a trivial 'strings' on the .exe file that indicates anything would try to load any newer d3dx9_*.dll modules, just d3dx9_27.dll.
  • User Avatar Image
    Just going by what the normal behavior and fix is for Windows stuff, which is sadly the limits to my knowledge on the issue. Sorry I can't be more helpful. :(
  • Oh snap - Wine 1.1.3 is out, and appears to include implementations of the d3dx9_*.dll libraries. Maybe this will fix the disappearing eyes... I'll have to check when I return from NYC.
  • confirming that the patch is no longer necessary from Wine 1.1.3. i've updated the first post to reflect this.

    didn't get the "no eyes" in the five minutes that i just played, but then again i've only seen it for a total of about 20 seconds on my machine.
  • Good news! (Though it may be premature; we'll see.) So far, with Wine 1.1.3, I haven't encountered the "disappearing eyes" issue in several tries of loading a saved game. Obviously this doesn't mean it's 100% solved, but previously I'd get it about 1 out of every 3-4 game loads - more often if the game had just been started. So for what it's worth, this *seems* to take care of the problem...

    Edit: The above statement has held thus far - no reoccurrences of the "disappearing eyes" problem thus far with Wine 1.1.3.

    edit 2: And it fails. For the first time in many attempts, Strong Bad's eyes are missing again. Oh well...
  • Hi all,

    I just cannot get passed that initial screen requesting the username and password information to get started. Even if I say to go directly to the demo, it just shows the screen with Strong Bad and Homestar, but just gray to their left where the menu is supposed to go. I followed all the instructions to the letter, having had to delete wine and ies4linux a couple of times just to get them going in the right order (it's all OK since I got to this point).

    When I try to log in it says:

    "Sorry, we weren't able to log you in. If you're connected to the internet, please use your serial number instead. Otherwise please go to the manual unlock tab and follow the instructions for offline activation"

    I've uploaded a screenshot, so you'll know what I mean by "gray." I think there is supposed to be a menu there. Could it have something to do with my settings with ie? ie seems to work fine (though I haven't tested it much other than the welcome screen). I am on a 64 bit system if that makes a difference, so of course flash and such is a pain in firefox itself. Can that be a problem here?

    *EDIT - The posted image is what I see after clicking "take me to the demo" or whatever that button was. The above still holds for the "sorry we weren't able... etc."
  • i think you're fine -- click in the grass to the left of Strong Bad's feet. if nothing happens, click around a bit more -- you might have to hunt a bit. there's meant to be a button there but it doesn't show up for some reason.

    your Firefox/Flash/64-bit stuff shouldn't be an issue.
  • tremby;89128 said:
    i think you're fine -- click in the grass to the left of Strong Bad's feet. if nothing happens, click around a bit more -- you might have to hunt a bit. there's meant to be a button there but it doesn't show up for some reason.

    your Firefox/Flash/64-bit stuff shouldn't be an issue.
    I tried that, and it sends me to a "the page cannot be displayed." I've posted another screenshot. It still seems a bit ominous that I cannot get in with the registration information anyway.

    Let me give you some more background as to my history in attempting to run this game in linux.

    I had wine 1.1.1 and for all intents and purposes, I've been able to run almost anything with it. I tried using it when I installed (blindly) sbcg4ap at first, and of course it didn't work. So that's when I began to scour through the internet and stumbled upon this thread. I subsequently deleted the folder (first also uninstalled the game using the uninstaller app) and installed ies4linux. Seemed to have trouble with the gui installation, but I finally got it to run. I then continued to follow the instructions and still with no avail.

    So I broke down and installed the new version of wine (1.1.4, after removing 1.1.1 of course) and started the process all over, but kept the first ies4linux. No avail. I then tore everything down and started from scratch (deleted the ~/.ies4linux folder ~/.wine_sbcg4ap and any other remnants I could find, though I think that's about it). I installed ies4linux and sbcg4ap still following the instructions and finally got to the point where I could see the splash screen asking for the information input. That's what puts us now where I currently am.

    I'm thinking there might be something wrong with the settings in IE6 to connect to the internet, or something to that effect. If you have any suggestions, please let me know. Thanks!
  • I also notice that when installing SBCG4AP, the directx window comes up and starts to install components for windows 98. Following your steps, you install the game first, and then configure wine afterward (change the dlls and force XP emulation). I reversed the steps and tried configuring the prefix in the folder (changed it to XP) before installing and it gets through part of the installation, but freezes when attempting to download the directx components (and it doesn't do that when the order is as you wrote, even though it downloads windows 98 components).

    I don't know if that has anything to do with it, but can you just confirm the order in which you indeed installed the game and configured the files? I've tried a lot of things, but nothing seems to get me past my problem area. Thanks for the help.
This discussion has been closed.