User Avatar Image

Possible SBCG4AP Bug: Can't progress in Homsar Reservation

posted by Galbrush Sheepgood on - last edited - Viewed by 612 users
(Not sure how to add spoiler text to my message, so know this bug description contains some spoilers for in game activity.)

I'm at the point in the game where I dropped all three necessary items into the rock formation. I put in the tuning fork and the three ring binder right away. I found these items with the metal detecTOR long before I entered the reservation and talked to Homsar.

Later I solved the puzzle with Bubs in order to get the pottery shard. I dropped it in, talked to Homsar, and he still speaks in half jibberish, half english. So I can't get into the cave and progress any further.

According to the walkthrough I have done exactly what I needed to do in order to progress. The fact I'm stuck in limbo makes me think I've encountered a bug. Or did I miss puzzle a step somewhere? Maybe my save point is corrupted?

If this is a bug, could it have been triggered by the order in which I tried to solve the puzzle? (dropping in the 2 items found with the detecTOR immediately, then later giving the pretendix to Bubs, getting the pottery shard and dropping it in.)

Sidenote: After reloading my save point right before I talk to Homsar, I get the dreaded eye dispearring bug on him. This is the first and only time I've witnessed this bug in Episode 2. (my DirectX is nice and updated.)
6 Comments - Linear Discussion: Classic Style
  • Did you drop in the power board as well?
  • Yeah its probably that.
  • There are four items to put into the pylon. Have you put all four in?
  • Hmm. I did try to put the power strip into the stone that I found with the detecTOR, but SB says I should try putting it somewhere else instead. Am I still missing a step?

    Going by these replies it looks like my problem is due to not solving a puzzle completely and isn't a bug, which is a good thing. :)
  • Nuroticat;90782 said:
    Hmm. I did try to put the power strip into the stone that I found with the detecTOR, but SB says I should try putting it somewhere else instead. Am I still missing a step?

    Going by these replies it looks like my problem is due to not solving a puzzle completely and isn't a bug, which is a good thing. :)
    I have a feeling you're inadvertently clicking SB himself, try stepping him off to the side and then adding it to the stone.
  • Krodge;90825 said:
    I have a feeling you're inadvertently clicking SB himself, try stepping him off to the side and then adding it to the stone.
    Yep, you're right. I was clicking on SB rather than the stone; how funny. Problem solved! Thanks!
This discussion has been closed.