The Walking Dead A New Frontier

The Walking Dead A New Frontier

Support

How do I know if The Walking Dead: A New Frontier is supported on my Android device?

We currently support the following GPUs:

  • Tegra K1 & X1
  • Adreno 418, 420, 430, and 530

Additional Requirements:

  • OpenGL 3.1 and above
  • OS6 Marshmallow and above (and select devices on OS5 that support OpenGL 3.1)

These are examples of currently supported devices:

  • Google Pixel & Pixel XL
  • Google Nexus 5X & 6P
  • Samsung Galaxy S7 & S7 Edge (Adreno only)
  • Sony Xperia X, XZ, Z4, & Z5
  • HTC One (M9) & 10

These are examples of unsupported devices:

  • Samsung Galaxy S6/S6 Edge and below
  • Google Nexus 5 and below
  • HTC One (M8) and below